Rewterz Threat Advisory – CVE-2018-5848 – Linux Kernel ‘wmi_set_ie()’ Buffer Overflow Vulnerability

Thursday, December 6, 2018

A vulnerability has been reported in Linux Kernel, which can be exploited by malicious, local users to potentially gain escalated privileges.

 

 

IMPACT:  NORMAL

 

 

PUBLISH DATE:  06-DEC-2018

 

 

OVERVIEW

 

 

An integer overflow error related to the “wmi_set_ie()” function (drivers/net/wireless/ath/wil6210/wmi.c) can be exploited to cause a buffer overflow.

 

 

ANALYSIS

 

 

In the function wmi_set_ie(), the length validation code does not handle unsigned integer overflow properly. As a result, a large value of the ‘ie_len’ argument can cause a buffer overflow in all Android releases from CAF (Android for MSM, Firefox OS for MSM, QRD Android) using the Linux Kernel.

 

 

The vulnerability is reported in versions 4.14.x prior to 4.14.86, 4.9.135, 4.4.162, and 3.16.60. Other versions may also be affected.

 

 

AFFECTED PRODUCTS

 

 

Linux Kernel 3.16.x

Linux Kernel 4.4.x

Linux Kernel 4.9.x

Linux Kernel 4.14.x

 

 

UPDATES

 

 

Update to a fixed version if available.

 

Versions 4.14.x:

Update to version 4.14.86.

 

Versions 4.4.x, 4.9.x, 3.16.x:

Fixed in the source code repository. (which means third-party patches are available, whereas no official updates by the vendor have been released so far.)

 

https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=b5a8ffcae4103a9d823ea3aa3a761f65779fbe2a

 

 

If you think you are a victim of a cyber-attack, immediately send an e-mail to soc@rewterz.com.

Data Sheets

Corporate Brochure


Our Story


Services


Solutions


Managed Security


Upcoming Rewterz Trainings/Events

Rewterz News

  • 13, December 2018 Rewterz Threat Advisory – Windows Server 2012/Windows RT 8.1/8.1 multiple vulnerabilities
  • 13, December 2018 Rewterz Threat Advisory – CVE-2018-8604 – Microsoft Exchange Server 2016 Profile Data Manipulation Vulnerability
  • 13, December 2018 Rewterz Threat Advisory – Microsoft Edge Memory Corruption Multiple Vulnerabilities
  • 13, December 2018 Rewterz Threat Advisory – CVE-2018-0732 – IBM Lotus Protector for Mail Security OpenSSL Denial of Service Vulnerability

Copyright © Rewterz. All rights reserved.