Rewterz Threat Advisory – CVE-2018-5848 – Linux Kernel ‘wmi_set_ie()’ Buffer Overflow Vulnerability

Thursday, December 6, 2018

A vulnerability has been reported in Linux Kernel, which can be exploited by malicious, local users to potentially gain escalated privileges.












An integer overflow error related to the “wmi_set_ie()” function (drivers/net/wireless/ath/wil6210/wmi.c) can be exploited to cause a buffer overflow.






In the function wmi_set_ie(), the length validation code does not handle unsigned integer overflow properly. As a result, a large value of the ‘ie_len’ argument can cause a buffer overflow in all Android releases from CAF (Android for MSM, Firefox OS for MSM, QRD Android) using the Linux Kernel.



The vulnerability is reported in versions 4.14.x prior to 4.14.86, 4.9.135, 4.4.162, and 3.16.60. Other versions may also be affected.






Linux Kernel 3.16.x

Linux Kernel 4.4.x

Linux Kernel 4.9.x

Linux Kernel 4.14.x






Update to a fixed version if available.


Versions 4.14.x:

Update to version 4.14.86.


Versions 4.4.x, 4.9.x, 3.16.x:

Fixed in the source code repository. (which means third-party patches are available, whereas no official updates by the vendor have been released so far.)



If you think you are a victim of a cyber-attack, immediately send an e-mail to

Data Sheets

Corporate Brochure

Our Story



Managed Security

Upcoming Rewterz Trainings/Events

Rewterz News

  • 12, February 2019 Rewterz Threat Alert – Phishing Campaign Targeting Bank Employees in Pakistan, Forging Zimbra
  • 11, February 2019 Rewterz Threat Alert -Malware Campaign Hides Ransomware in Super Mario Wrapper
  • 11, February 2019 Rewterz Threat Alert – New Linux coin miner kills competing malware to maximize profits
  • 8, February 2019 Rewterz Threat Advisory -CVE-2018-11803 – Apache Subversion Denial of Service Vulnerability

Copyright © Rewterz. All rights reserved.